Solved-Ruby on Rails Error, "warn_for_outdated_bundler_version" You must use Bundler 2 or greater with this lockfile"

Error: "warn_for_outdated_bundler_version': You must use Bundler 2 or greater with this lockfile."

Solution

When developing using Ruby on Rails you might experience this error "warn_for_outdated_bundler_version': You must use Bundler 2 or greater with this lockfile." when starting Rails Server (rails s -b 0.0.0.0). What this error is telling you is that the version of Bundler installed on your computer (along with other dependencies ) is different from the version of Bundler defined in the Gemfile.lock file or in the Gemfile. One way to solve this problem is by backing up your Gemfile.lock file and eventually removing the Gemfile.lock file from your project, then in your command console, type: bundler update (bundler install might resolve this issue but if the version of bundler defined in the Gemfile is not equal to the version installed on your computer then this problem might persist).