Ruby on Rails Bundle Install Error: Could not find concurrent-ruby-1.1.5.gem for installation

Bundle Install Error: Could not find concurrent-ruby-1.1.5.gem for installation

Problem:
Ruby on Rails Server Error after pulling from a remote Github branch. This error happens most often when the configuration in GemFile.lock or GemFile has changed. Sometimes, Rails Server won't even start and the Git Working tree gets corrupted.

In general, if you see an error that says Could not find libraryName-rails-ThenVersionOfTheLibrary for installation chances are that you did bundle update which went through the GemFile and tried to update every dependency that did not lock the version. While attempting to update, Bundler did not find any Gems installed for those versions of the dependencies. That is why the error came up.

Solution:
  • Pay attention to the errors the log show and follow to install the dependencies listed in the log file that is causing the error.
  • If possible, stop all applications consuming the repository or the Working Tree you are trying to merge with the latest pull from a remote branch. For example, close the IDE you are using to edit the application and only use one Shell Console to access your local Repository.
  • BackUp the application in another folder and then Delete the Vendor's folder
  • After backing up the application, delete the GemFile.lock file
  • do: bundle install, when the installation succeeds then do: rails s -p 30012, the server successfully starts, try to access your application on localhost:30012. 
  • If nothing happens, go this website and see what version of concurrent-ruby is at:
  • In general, first, install or google search the dependency name and install it first using gem install dependency name. This will install the library and when you do bundle update, it will update because the library is already installed your local machine.